Back to overview
Resolved

Platform performance and capacity improvements

Jul 29, 2026 at 4:00pm UTC  –  Jul 29, 2026 at 5:30pm UTC
Affected services
Web Application

Resolved
Jul 29, 2026 at 5:30pm UTC

Testing completed successfully. HotPilot automatically adds capacity as traffic increases, and we've confirmed this is working as expected. Everything is operating normally.

Created
Jul 29, 2026 at 4:00pm UTC

We're carrying out planned performance testing on HotPilot to confirm the platform scales smoothly during periods of high demand.

Some pages may load more slowly than usual for a short period. Bookings, guest data and integrations are unaffected, and the platform remains fully available throughout.